15 Feb 2009 avdyk   » (Journeyer)

MDR is not DFSG-compatible

Wolfgang was right about SPL not being free. MDR is a library that ArgoUML will use. ArgoUML is in contrib at the moment because of Swing issues so it can't be built and run with free software, but there are a lot of progresses in free Classpath based runtime. But now that ArgoUML will switch to MDR, we have another problem: SPL. It seems that SPL is not DFSG-compatible. Bad. I filed an issue on the Netbeans website (Issue#73161) to ask if they could change the license to one DFSG-compatible. If it's not possible, I'll have to package MDR to non-free and leave ArgoUML in contrib.

Syndicated 2009-02-15 14:10:00 (Updated 2009-02-15 14:10:39) from Arnaud Vandyck

Latest blog entries     Older blog entries

New Advogato Features

New HTML Parser: The long-awaited libxml2 based HTML parser code is live. It needs further work but already handles most markup better than the original parser.

Keep up with the latest Advogato features by reading the Advogato status blog.

If you're a C programmer with some spare time, take a look at the mod_virgule project page and help us with one of the tasks on the ToDo list!